Home > VansAirForceForums

- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

Old 08-04-2017, 05:01 AM
rwtalbot rwtalbot is offline
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 234
Default Garmin GAP-25 Pitot Tube Problems

Not long after I installed my Garmin GAP-26 heated pitot tube the plating came off the front. I think it was caused by flying through rain. Over time the front of the tube has corroded. It’s not a safety concern, just looks unsightly. Am I the only one?

Richard Talbot
Sydney, Australia
Reply With Quote
Old 08-04-2017, 07:31 AM
g3xpert's Avatar
g3xpert g3xpert is offline
Join Date: Sep 2010
Location: Olathe, KS
Posts: 1,808

Hello Richard,

We would be happy to work with you on this.

Please contact us at the email below.

Garmin G3X Support
1-866-854-8433 - 7 to 7 Central Time M to F
Please email us for support instead of using Private Messaging due to the limitations of the latter.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -6. The time now is 06:38 PM.

The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.