VansAirForceForums  
Home > VansAirForceForums

- POSTING RULES
- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

  #1  
Old 02-16-2018, 11:26 AM
guccidude1 guccidude1 is offline
 
Join Date: Mar 2008
Location: Reno NV
Posts: 512
Default Low battery voltage

I have been chasing a low voltage on my SV-T for about a year. My voltage started going down from 14.2 to as low as 13.2 vdc. As the amp load increased the volts would decrease. I initially suspected the Alternator so I had it tested at the aviation aisle of O'Riellys, tested good at 14.2 with 20 amp load. Then I started cleaning cable connections, new ground wire, nothing helped. I was told it is above 12 vdit is good enough.
Finally, I found it, or better said it found me. I have an avionics switch breaker and it failed in flight last week. I smelled a whiff of electrical something burning/really hot and RTB with minimum load, no CBs popped. The avionics switch was not engaging, completely loose in the unit. I replace it with new 20 amp unit and guess what? I now have 14.3 vdc and the volts do not decrease as the amp load increases. Who would have thunk it? Dan from Reno.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 09:21 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.