VansAirForceForums  
Home > VansAirForceForums

- POSTING RULES
- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

Prev Previous Post   Next Post Next
  #1  
Old 07-16-2017, 12:34 PM
istrumit's Avatar
istrumit istrumit is offline
 
Join Date: Nov 2015
Location: Franklin, TN
Posts: 183
Default Never talk down an issue

I've had a few issues in the last few weeks.

A main bus voltage reading low/zero and an oil pressure reading dropping out.

The local avionics shop cleaned some pins and all was normal.

So. On my way back from a weekend flight out of town, I started hearing a persistent whine in my headset. Out of curiosity I flipped over to the engine monitoring page and both bus voltages were out of range high. Off scale.

Then I started smelling something hot, very hot.

I turned off the master and pulled all the breakers.

Landed nearest which was about 7 long minutes.

I don't know what I have to fix, but it's sitting in kind strangers hangar until it's fixed.

Lesson learned. Never fly with a mystery reading.
__________________
Scott Martin
N430WP RV-10 - Purchased
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 02:53 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.