VansAirForceForums  
Home > VansAirForceForums

- POSTING RULES
- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

  #11  
Old 08-21-2019, 11:36 AM
lr172 lr172 is offline
 
Join Date: Oct 2013
Location: Schaumburg, IL
Posts: 4,542
Default

Quote:
Originally Posted by FORANE View Post
Tape works well at preventing rain erosion however...
It is hard to get the tape to adhere to the curved tip of the blade without buckling and failing in that location.
Due to the above, the tip is unprotected and erodes on the leading edge.
After one good flight through rain, my experience is the tape gets damaged to the point that it requires replacement.

I have an older 3 blade Catto on my garage wall due to too much leading edge damage flying through rain, mist, etc. If it were one of his newer ones with the nickel leading edge, I would likely still be flying it today.
I think this is an installation issue. I had that issue the first time I put tape on, but the second time has been 100 hours and no issue. It does separate at the very edge and Craig recommends a drop of super glue to hold it there.

To the OP, installation is straight forward. I got finger prints on the first attempt. Second attempt was much better. Like most things in life, practice makes perfect.
Larry
__________________
N64LR
RV-6A / IO-320, Flying as of 8/2015
RV-10 in Phase I
Reply With Quote
  #12  
Old 08-24-2019, 03:46 PM
ALagonia ALagonia is offline
 
Join Date: Jul 2017
Posts: 303
Default

I put the LET on my three blade Catto prop today. Learning curve is an understatement. First prop looks terrible. Second prop almost as bad. Third prop is acceptable.
Question for those that have used the LET more than one time - how do I remove the tape without damaging the painted prop blade?
I simply canít live with my installation of the first two prop blades but am terrified the paint will come off.
Help please.
Reply With Quote
  #13  
Old 08-24-2019, 07:14 PM
lr172 lr172 is offline
 
Join Date: Oct 2013
Location: Schaumburg, IL
Posts: 4,542
Default

Quote:
Originally Posted by ALagonia View Post
I put the LET on my three blade Catto prop today. Learning curve is an understatement. First prop looks terrible. Second prop almost as bad. Third prop is acceptable.
Question for those that have used the LET more than one time - how do I remove the tape without damaging the painted prop blade?
I simply canít live with my installation of the first two prop blades but am terrified the paint will come off.
Help please.
Pretty sure I just pulled it off. Heat always helps with this type of task and I may have used a heat gun to soften up the adhesive.

Larry
__________________
N64LR
RV-6A / IO-320, Flying as of 8/2015
RV-10 in Phase I
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 04:59 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.