VansAirForceForums  
Home > VansAirForceForums

- POSTING RULES
- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

  #11  
Old 02-10-2015, 02:19 PM
bkthomps bkthomps is offline
 
Join Date: Jan 2010
Location: Destin/Atlanta
Posts: 1,510
Default

Quote:
Originally Posted by Christian Gather View Post
I'm not sure who told you this but feel free to call me at 631-327-2632 should you need anything.
thanks for taking care of me today, I'll note my original post to reflect that
__________________
Brian
RV7 - Finishing, Who knows, make me an offer
Lancair Super ES-TN - G3X Touch/GTN
RV4 - Skyview Sold!
Reply With Quote
  #12  
Old 02-26-2015, 05:13 PM
Maxrate Maxrate is offline
 
Join Date: Dec 2008
Location: League city, TX
Posts: 383
Default

Just a quick report. I called Aveo and they had me send a picture of the discolored light. After looking over the pic, he told me to send them the old light and quickly shipped a new one with very few questions asked. One caveat, if you make a purchase from aveo be sure to register the product on line to get the lifetime warranty. Thanks for all the replies. It looks like their customer support has made great strides!
__________________
Mark Malone, RV7
Wings complete, SB 14 complied with, fuselage in progress.
N442MM reserved
http://www.mykitlog.com/MikeMike

2017 Donation gladly paid.
Reply With Quote
  #13  
Old 04-20-2018, 02:32 PM
FasGlas's Avatar
FasGlas FasGlas is offline
 
Join Date: Mar 2014
Location: Prescott, AZ
Posts: 518
Default

I know this thread is a few years old but I just notice that the Powerburst Nav/Strobe lights I installed on my Lancair have turned yellow. My plane is always hangared. I was touching up some paint near a wing tip and noticed that the once clear lights are yellow. I emailed Aveo, I'll see what they have to say. I would think that defusing the light output renders the Nav/Strobe less effective.

Last edited by FasGlas : 04-20-2018 at 06:01 PM.
Reply With Quote
  #14  
Old 04-20-2018, 02:49 PM
gyoung's Avatar
gyoung gyoung is offline
 
Join Date: Jan 2005
Location: Spring, TX
Posts: 164
Default

One of my tip pos/strobe lights had a partial failure and the metal was being exposed thru the plastic. (erosion/migration/shrinkage... dunno) I had a conversation with them at Oshkosh. They had me send them in and replaced both since my model has been replaced. The new ones fit the same, work better and obviously look better. We'll see how they fare in another few years.
__________________
Greg

1950 Navion - flying
RV-6 - 16 yrs and 98.1% done
1940 Rearwin Cloudster project next
3.5 L-2 projects on deck
Reply With Quote
  #15  
Old 06-13-2018, 02:12 PM
FasGlas's Avatar
FasGlas FasGlas is offline
 
Join Date: Mar 2014
Location: Prescott, AZ
Posts: 518
Default Replaced

Well, I have to admit... The new Aveo LED's are far better then the originals. I contacted Aveo about my Powerburst LED's that turned yellow. I sent my yellow LED's to them and after a painfully long wait Aveo sent me the new version of the Powerburst LED's. They are obviously a much more robust design, brighter Cree LED's, better cabling, a stronger aluminum backing and a new encapsulating compound (I hope does not yellow). I was told that Aveo has a trade in program for $100 to upgrade from the old to the new. IMO a good upgrade for the price.


Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 08:28 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.