VansAirForceForums  
Home > VansAirForceForums

- POSTING RULES
- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

  #1  
Old 04-30-2019, 02:52 PM
mike newall's Avatar
mike newall mike newall is offline
 
Join Date: Jan 2005
Location: Yorkshire, England
Posts: 1,790
Default Garmin 430 battery replacement

Garmin 430 had message saying backup battery needs replacing.

Replaced as shown in various YouTube vids but it still shows backup battery message.

Is the message a latching message that needs clearing via a menu ?

Thanks
__________________
"I add a little excitement, a little spice to your lives, and all you do is complain!" - Q

Donated in 2019
Reply With Quote
  #2  
Old 04-30-2019, 03:32 PM
midwest rv-10's Avatar
midwest rv-10 midwest rv-10 is offline
 
Join Date: Oct 2008
Location: Pleasant Prairie,Wisconsin
Posts: 65
Default GNS430 memory battery

I replaced mine a few years ago and it cleared on its own.
Reply With Quote
  #3  
Old 04-30-2019, 03:38 PM
midwest rv-10's Avatar
midwest rv-10 midwest rv-10 is offline
 
Join Date: Oct 2008
Location: Pleasant Prairie,Wisconsin
Posts: 65
Default correct battery voltage?

just thought about this. did you check the voltage of the new battery to be sure its voltage is correct. a battery that has laid around on the shelf for years could be stale and dropped a volt or so. I think it's only a 3.5 volt battery.
Reply With Quote
  #4  
Old 04-30-2019, 04:26 PM
sglynn's Avatar
sglynn sglynn is offline
 
Join Date: Mar 2008
Location: Anacortes, WA
Posts: 791
Default

Quote:
Originally Posted by mike newall View Post
Garmin 430 had message saying backup battery needs replacing.

Replaced as shown in various YouTube vids but it still shows backup battery message.

Is the message a latching message that needs clearing via a menu ?

Thanks
Yes, they go bad and have to be replaced. I had to buy it thru avionics shop. A few years ago I received a dead battery from Garmin. They were shipping bad batteries. Did you test your "new" battery? I just replaced it again earlier this year and all is fine.
__________________
Steve Lynn
RV-7A
Flying Phase I
Anacortes, WA
www.mykitlog.com/sglynn
Reply With Quote
  #5  
Old 05-01-2019, 03:29 AM
mike newall's Avatar
mike newall mike newall is offline
 
Join Date: Jan 2005
Location: Yorkshire, England
Posts: 1,790
Default

Issue seems to be the number of boards it gets attached to. Our 'spert is on it again and is allegedly paying more attention.

Hopefully it will be tested satis this evening
__________________
"I add a little excitement, a little spice to your lives, and all you do is complain!" - Q

Donated in 2019
Reply With Quote
  #6  
Old 05-01-2019, 05:13 AM
FORANE's Avatar
FORANE FORANE is online now
 
Join Date: Nov 2011
Location: East TN
Posts: 521
Default

2 possible issues:
Battery has 3 pins that need to be soldered to the board. Inadequate soldering will result in a message upon startup. Second possibility is a weak battery that you installed. I received a brand new battery weaker than the one that we were replacing.
__________________
Lancair 235/320
RV-9A (2013 - 2016)
Reply With Quote
  #7  
Old 05-16-2019, 02:06 AM
mike newall's Avatar
mike newall mike newall is offline
 
Join Date: Jan 2005
Location: Yorkshire, England
Posts: 1,790
Default

Now sent for diagnosis at local avionics shop and looks like a board fault. Hoping to do a trade in - certainly not sending back to Garmin
__________________
"I add a little excitement, a little spice to your lives, and all you do is complain!" - Q

Donated in 2019
Reply With Quote
  #8  
Old 05-16-2019, 05:18 PM
blaplante blaplante is offline
 
Join Date: Jan 2010
Location: Southern California
Posts: 102
Default Keep us updated

I'll be interested in the outcome. I've got a 430 that eats batteries. I put one in and it last 6 weeks or so... then starts reporting low battery again. Been through this a few times.

I'm getting tempted to bring the wires out the back so I can use a couple AAA's and be able to change them without pulling and opening the box each time.
__________________
RV6A in phase 2 as of April 2016
Donation made Sept 2019
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 05:36 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.