VansAirForceForums  
Home > VansAirForceForums

- POSTING RULES
- Donate yearly (please).
- Advertise in here!

- Today's Posts | Insert Pics

  #51  
Old 08-26-2017, 05:40 PM
jimgreen jimgreen is offline
 
Join Date: Apr 2006
Location: Vancouver island, BC Canada
Posts: 363
Default

Mystery solved with the flickering light on my PlanePower alternator.
That darned light has been flickering faintly for at least 100hrs, even though it has always produced good power. The alternator has been bench tested but not disassembled
The alternator finally quit at 261 hrs, so it went to our local shop and $120+tax later it is back in service.
The fix was a new stator. Turns out the stator is not keyed into position, but merely clamped by the case screws. In this case there was slight rotational movement as evident from the chafing marks, and over time this broke the connections to the stator. Needless to say the new stator is fixed, I believe with a Loctite product.
No more flicker.
__________________
Jim Green
RV7 tip up
IO360 Whirlwind 200RV
Building RV8 with buddy
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 11:51 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.