VAF Forums

VAF Forums (http://www.vansairforce.com/community/index.php)
-   ADS-B (http://www.vansairforce.com/community/forumdisplay.php?f=113)
-   -   Uavionix Echo w/MUX - GRT HX - GNS 430W - GTX 327 (http://www.vansairforce.com/community/showthread.php?t=176941)

kreidljj 11-15-2019 08:15 PM

Uavionix Echo w/MUX - GRT HX - GNS 430W - GTX 327
 
We have been working to get our Uvionix Echo up and running in our RV-10. We tried the wireless options but were not satisfied with the performance, we were unable to get a passing grade. We installed the GNS MUX Cable from Uavionix. The MUX gets GPS data from the 430W, encoded altitude from the GRT HX (set to 9600 Fuel Air Data Z), transponder squawk from the GTX 327 (set to remote out). The ADS-B data is broadcast back to the GRT HX.

The problem is that we can not get pressure altitude or transponder squawk. We have tried piles of configuration settings per other success stories on here.

The last thing to try (I think) is to upgrade the firmware on the GTX 327 from 2.09 to 2.13, however others on the forum have had success with the GTX 327 working on previous versions of firmware. Can anyone confirm the upgrade is necessary? Any other ideas to try? Garmin says an update is not required, Uavionix says it has to be....

Thanks in advance - Jason

Solved: I got a call back from Uavionix and they told me that they had a run of MUX cables that were programmed incorrectly. I had to change COM1 to 38400 Baud and keep the other settings per their instructions. I am now seeing altitude from the GRT and squawk from the GTX 327. HOWEVER, meanwhile I had the firmware of the GTX 327 upgraded to 2.13, so it is not clear to me if the update to the GTX firmware was actually required. Thanks for all the advice. - Jason

FireMedic_2009 11-15-2019 10:39 PM

EchoUAT
 
Hi Jason
Did you adjust the transponder threshold in the Echo app? If not, then that is the problem. Call me and I can walk you through it. It actually is fairly easy. I emailed you with my number
Daren

kreidljj 11-16-2019 06:16 AM

Yes - Tried 4 values
 
Quote:

Originally Posted by FireMedic_2009 (Post 1386596)
Hi Jason
Did you adjust the transponder threshold in the Echo app? If not, then that is the problem. Call me and I can walk you through it. It actually is fairly easy. I emailed you with my number
Daren

Daren, thanks for the reply - yes we tried 4 different values and got as low as 2.5% failure rate. Still not passing, that is what sent us down the path of the MUX cable. - Jason

BH1166 11-16-2019 08:48 AM

So you have no red on the PAPR (report) except for 3A and Baro Alt ? If so congratulations on getting WAAS gps connected correctly. Your transponder is not being seen. If not wired in, this is as Daren said, threshold/sensitivity needs to be adjusted. EchoUAT is looking for a very small voltage mv/micro volt that has your sqwk and pressure altitude, lowering sensitivity, helps find it. I cannot help you with wiring this in, but do know that the above is accurate. If you are not 100% sure, go fly and get someone to confirm they see your sqwk and altitude from your transponder. Recently went through this, bad transponder for me, was working and quit. Repaired and now have all zeros on the report....perfect. I had to drop my threshold to 1000 to get all good. I was told by EchoUAT support to do so contrary to what I had heard, never below 1100. FYI, you should not go any lower than necessary. I went from 1100 to 1050 ang got some intermittent issues...down to 1000, rock solid. Like Darren, PM if you want to chat about it. Good luck. 🍀

Fox3twoship 11-17-2019 08:22 AM

Hi Jason,

A kindred spirit here. You and I seem to be having almost the exact SAME problem at the exact SAME time. I am also running out of ideas.

My setup: GTX327, EchoUAT (with their skyFYX gps), MUX cable, and AFS-3500 for the pressure altitude source. Cable/pins installed via a qualified avionics shop. The installer confirmed the pin configuration with the uAvionix tech. Also confirmed all txpdr setting are correct (Remote) and the app settings are correct in EFIS/Panel Control Source.

We are also unable to get any pressure altitude or squawk to Echo when using MUX cable. Transponder screen does display the pressure altitude so the info is getting from my EFIS to the txpdr.

The exact date of your original post I was up at SteinAir having my GTX-327 software updated (great people at SteinAir btw....) from 2.09 to 2.13, in hopes of solving this same issue. Txpdr software update was a long shot, but am trying to remove as many variables as possible. Unfortunately, the software update had no effect on this problem. Transponder was working fine according to SteinAir.

Currently, the MUX cable and Echo are enroute back to uAvionix to check if there is a hardware problem with either of those.

You (or anyone...) have any other ideas/inputs are greatly appreciated!
Ken

BH1166 11-17-2019 09:06 AM

Ken, since you are using skyFYX, for position data you only need to supply power and ground, and place gps antenna for clear view above, ADSB antenna on bottom of RV per uAvionix’s installation doc. Then using the app on iOS capable device configure. Pressure altitude is attached to transponder code, one data packet with both components. Both code and pressure are found in electrical system that the EchoUAT picks up, no hard wiring required, but IS necessary should you want UAT control/configuration via EFIS AND want traffic and weather to display on EFIS. Short answer.... leave off wiring other than required (as if you have no EFIS only mode c transponder) configure per app, go fly. All good, then it is the wiring to EFIS that is challenging you. Pretty sure if you are wanting pressure altitude via wired to EFIS, you also will need to get transponder code from wired EFIS. Not wired in one and not both. I recommend all install free standing first , it’s easy, then tackle interfacing with EFIS etc. Good luck....yes I am a retire “propeller head/geek.

Piper J3 11-17-2019 02:23 PM

You might want to look here...http://www.vansairforce.com/communit...onix+mux+cable

I installed MUX with 327 and echoUAT/SkyFYX-EXT. I still have an occasional PAPR failure for Baro Alt A. It appears that the FAA acceptable limit for Baro Alt is < 1.5% is OK. Sometimes I get report with value approaching 2.

Fox3twoship 11-17-2019 04:25 PM

Thanks Butch. Yes the GPS installed fine with supplied wiring. Am not wiring any info back to the AFS3500, since it not able to display tracks/wx. Ironically, I am able to get the echoUAT working fine in the wireless/sniff mode with all associated settings/baud rates seeing the transponder output and PA and get a good PAPR. But wanted the hardwired side for more reliability. Just didn't think I'd run into this much trouble getting the wired side up to speed.

Thanks Jim. That link is a good read. Appears you had similar frustrations. But now sounds like you got the MUX to 'work' but not great? Any idea what you did to get the PA and squawk flowing? Thanks for the pin/wiring drawing, I'll crosscheck it with my installer.

kreidljj 11-17-2019 04:31 PM

Ken, that is not encouraging... I am going to call Uavionix in the morning and see what they recommend. Thanks for the response - Jason

kreidljj 11-17-2019 04:36 PM

Jim, I read that thread through several times during troubleshooting. What concerns me most about the sniffing option is the table that you showed, specifically how you could fly twice with a value of 1300, pass once and fail another time. Not a warm and fuzzy feeling. - Jason


All times are GMT -6. The time now is 10:10 AM.